summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola2014-11-02 23:06:15 +0100
committerKarel Zak2014-11-18 12:55:41 +0100
commit4f310faee0721d52bd9c68dac88c9169f09b5e72 (patch)
tree14b67d19cc61675bb92282644d7d114c8f42ec1b /configure.ac
parentlscpu: theoretical buffer overflow (diff)
downloadkernel-qcow2-util-linux-4f310faee0721d52bd9c68dac88c9169f09b5e72.tar.gz
kernel-qcow2-util-linux-4f310faee0721d52bd9c68dac88c9169f09b5e72.tar.xz
kernel-qcow2-util-linux-4f310faee0721d52bd9c68dac88c9169f09b5e72.zip
build-sys: make scanf_cv_alloc_modifier to work [LeakSanitizer]
The tests failed with following message in config.log ERROR: LeakSanitizer: detected memory leaks Direct leak of 2 byte(s) in 1 object(s) allocated from: #0 0x49a40e in realloc (/home/src/util-linux/conftest+0x49a40e) #1 0x7fbe48633e69 in __GI__IO_vfscanf (/usr/lib/libc.so.6+0x56e69) #2 0x7fbe48649786 in _IO_vsscanf (/usr/lib/libc.so.6+0x6c786) which knocked out libmount from build, and commands depending on it. The reason this change makes sense is that AddressSanitizer seems like a good addition to set of tools that util-linux package can use, when and if needed. Reference: https://code.google.com/p/address-sanitizer/wiki/AddressSanitizer Reviewed-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1336f8d14..b8a6627ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -461,6 +461,7 @@ int main()
int i;
char *s;
i = sscanf("x", $1, &s);
+ free(s);
if (i == 1)
return 0;
return 1;