summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-06-01 16:15:29 +0200
committerKarel Zak2012-06-26 20:50:53 +0200
commit50ea67950994d05151fb1c3da57aeebc1554f289 (patch)
tree5978848cc031ace9d10a36e40bb03b98aeb6bc91 /configure.ac
parentbuild-sys: convert tests/ to module (diff)
downloadkernel-qcow2-util-linux-50ea67950994d05151fb1c3da57aeebc1554f289.tar.gz
kernel-qcow2-util-linux-50ea67950994d05151fb1c3da57aeebc1554f289.tar.xz
kernel-qcow2-util-linux-50ea67950994d05151fb1c3da57aeebc1554f289.zip
build-sys: rename fdisk -> fdisks/, convert to module
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 14 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 6e6399f36..af7aca615 100644
--- a/configure.ac
+++ b/configure.ac
@@ -610,27 +610,32 @@ AC_ARG_WITH([slang],
AS_HELP_STRING([--with-slang], [compile cfdisk with slang]),
[], with_slang=no
)
-
-have_tinfo=no
-AC_CHECK_LIB(tinfo, tgetent, [have_tinfo=yes])
-AM_CONDITIONAL(HAVE_TINFO, test "x$have_tinfo" = xyes)
-
-use_slang=no
+have_slang=no
if test "x$with_slang" = xyes; then
AC_CHECK_HEADERS([slang.h slang/slang.h])
AC_CHECK_HEADERS([slcurses.h slang/slcurses.h],
- [use_slang=yes], [], [
+ [have_slang=yes], [], [
#ifdef HAVE_SLANG_H
#include <slang.h>
#elif defined(HAVE_SLANG_SLANG_H)
#include <slang/slang.h>
#endif
])
- if test "x$use_slang" = xno; then
+ if test "x$have_slang" = xno; then
AC_MSG_ERROR([slang selected but slcurses.h not found])
fi
fi
-AM_CONDITIONAL(USE_SLANG, test "x$use_slang" = xyes)
+AM_CONDITIONAL(HAVE_SLANG, test "x$have_slang" = xyes)
+
+
+if test "x$have_slang" = xyes -o "x$have_ncurses" = xyes; then
+ AM_CONDITIONAL(BUILD_CFDISK, true)
+fi
+
+
+have_tinfo=no
+AC_CHECK_LIB(tinfo, tgetent, [have_tinfo=yes])
+AM_CONDITIONAL(HAVE_TINFO, test "x$have_tinfo" = xyes)
AC_ARG_WITH([utempter],
@@ -1290,7 +1295,6 @@ AC_CONFIG_HEADERS(config.h)
AC_CONFIG_FILES([
Makefile
-fdisk/Makefile
libblkid/blkid.pc
libblkid/docs/Makefile
libblkid/docs/version.xml