summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Luscon2011-12-08 16:10:18 +0100
committerKarel Zak2012-03-27 13:04:58 +0200
commit539feec175651a33cf8df5da488af7e902e6d2ee (patch)
tree9cd1af83a87ff7ce631790224ac7f74739558e7c /configure.ac
parentbuild-sys: move obsolete lib/fsprobe to mount/ (diff)
downloadkernel-qcow2-util-linux-539feec175651a33cf8df5da488af7e902e6d2ee.tar.gz
kernel-qcow2-util-linux-539feec175651a33cf8df5da488af7e902e6d2ee.tar.xz
kernel-qcow2-util-linux-539feec175651a33cf8df5da488af7e902e6d2ee.zip
eject: initial merge eject and util-linux
Signed-off-by: Michal Luscon <mluscon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2140bc596..4e9b5f4ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -862,6 +862,14 @@ ruman1dir='${mandir}/ru/man1'
AC_SUBST([ruman1dir])
+AC_ARG_ENABLE([eject],
+ AS_HELP_STRING([--disable-eject], [do not build eject]),
+ [], enable_eject=yes
+)
+UL_BUILD_INIT([eject])
+UL_REQUIRES_LINUX([eject])
+
+
AC_ARG_ENABLE([agetty],
AS_HELP_STRING([--disable-agetty], [do not build agetty]),
[], enable_agetty=yes
@@ -870,6 +878,8 @@ UL_BUILD_INIT([agetty])
AM_CONDITIONAL(BUILD_AGETTY, test "x$build_agetty" = xyes)
+
+
AC_ARG_ENABLE([cramfs],
AS_HELP_STRING([--disable-cramfs], [do not build fsck.cramfs, mkfs.cramfs]),
[], enable_cramfs=check