summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Lutomirski2013-01-14 16:58:57 +0100
committerKarel Zak2013-02-05 10:35:33 +0100
commit5600c405d5f1b12cad94915014e7cb46bf8fb746 (patch)
treef453cc2e60983039c4a0ab4add394e94c8e3b9e4 /configure.ac
parentlibblkid: add blkid_probe_step_back() (diff)
downloadkernel-qcow2-util-linux-5600c405d5f1b12cad94915014e7cb46bf8fb746.tar.gz
kernel-qcow2-util-linux-5600c405d5f1b12cad94915014e7cb46bf8fb746.tar.xz
kernel-qcow2-util-linux-5600c405d5f1b12cad94915014e7cb46bf8fb746.zip
setpriv: run a program with different Linux privilege settings
This new command can set no_new_privs, uid, gid, groups, securebits, inheritable caps, the cap bounding set, securebits, and selinux and apparmor labels. [kerolasa@iki.fi: a lot of small adjustment making the command to be good fit to util-linux project] Signed-off-by: Sami Kerola <kerolasa@iki.fi> Signed-off-by: Andy Lutomirski <luto@amacapital.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9024809e7..d3a8e9e7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -879,6 +879,20 @@ if test "x$build_nsenter" = xyes; then
AC_CHECK_FUNCS([setns])
fi
+dnl setpriv depends on libcap-ng. It would be possible to build
+dnl a version of setpriv with limited functionality without libcap-ng,
+dnl but this isn't currently supported.
+UL_CHECK_LIB([cap-ng], [capng_apply], [cap_ng])
+AC_ARG_ENABLE([setpriv],
+ AS_HELP_STRING([--disable-setpriv], [do not build setpriv]),
+ [], enable_setpriv=check
+)
+UL_BUILD_INIT([setpriv])
+UL_REQUIRES_LINUX([setpriv])
+UL_REQUIRES_HAVE([setpriv], [cap_ng], [libcap-ng])
+AM_CONDITIONAL(BUILD_SETPRIV, test "x$build_setpriv" = xyes)
+
+
AC_ARG_ENABLE([arch],
AS_HELP_STRING([--enable-arch], [do build arch]),
[], enable_arch=no