summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-05-04 11:45:35 +0200
committerKarel Zak2012-05-04 11:45:35 +0200
commit5b0289b9cfe7bfc1092a097a9aa8ea4f38d72431 (patch)
tree70f00f67c292bb1b4a52997bebe205f5e794e440 /configure.ac
parentwdctl: add man page (diff)
downloadkernel-qcow2-util-linux-5b0289b9cfe7bfc1092a097a9aa8ea4f38d72431.tar.gz
kernel-qcow2-util-linux-5b0289b9cfe7bfc1092a097a9aa8ea4f38d72431.tar.xz
kernel-qcow2-util-linux-5b0289b9cfe7bfc1092a097a9aa8ea4f38d72431.zip
build-sys: add BUILD_WDCTL, check for linux/watchdog.h
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 56f378ebb..b5f3d5700 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,6 +139,7 @@ AC_CHECK_HEADERS([ \
inttypes.h \
linux/cdrom.h \
linux/falloc.h \
+ linux/watchdog.h \
linux/fd.h \
linux/raw.h \
linux/tiocl.h \
@@ -182,6 +183,7 @@ AC_CHECK_HEADERS([langinfo.h],
dnl Convert some ac_cv_header_* variables to have_*
dnl
have_linux_raw_h=$ac_cv_header_linux_raw_h
+have_linux_watchdog_h=$ac_cv_header_linux_watchdog_h
have_security_pam_misc_h=$ac_cv_header_security_pam_misc_h
@@ -919,6 +921,12 @@ UL_REQUIRES_HAVE([chcpu], [cpu_set_t], [cpu_set_t type])
AM_CONDITIONAL(BUILD_CHCPU, test "x$build_chcpu" = xyes)
+UL_BUILD_INIT([wdctl], [check])
+UL_REQUIRES_LINUX([wdctl])
+UL_REQUIRES_HAVE([wdctl], [linux_watchdog_h], [linux/watchdog.h header file])
+AM_CONDITIONAL(BUILD_WDCTL, test "x$build_wdctl" = xyes)
+
+
UL_BUILD_INIT([prlimit], [check])
UL_REQUIRES_LINUX([prlimit])
UL_REQUIRES_SYSCALL_CHECK([prlimit], [UL_CHECK_SYSCALL([prlimit64])], [prlimit64])