summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2016-12-08 14:29:44 +0100
committerKarel Zak2016-12-08 15:27:24 +0100
commit5c493bd92f1a6858e9cb5c98d667b0aabd945b28 (patch)
tree9e9f8d4dad977cb52c281aaf42b8138d3efdf896 /configure.ac
parentlibmount: introduce X-* comments (diff)
downloadkernel-qcow2-util-linux-5c493bd92f1a6858e9cb5c98d667b0aabd945b28.tar.gz
kernel-qcow2-util-linux-5c493bd92f1a6858e9cb5c98d667b0aabd945b28.tar.xz
kernel-qcow2-util-linux-5c493bd92f1a6858e9cb5c98d667b0aabd945b28.zip
libmount: use x-systemd options as X-*
The previous patch introduces X-* options namespace for options that have to be maintained in user space. Unfortunately, systemd users already use mount options that are necessary by umount or another operations. The conclusion from discussion with systemd guys is to store all the systemd options in userspace. It seems better to add one line exception to libmount than force all fstab users to rename x-systemd to X-systemd. Addresses: https://github.com/systemd/systemd/pull/3904 Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08e06ffab..e0240b322 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1971,6 +1971,7 @@ AS_IF([test "x$with_systemd" != xno], [
[AC_MSG_ERROR([systemd expected but libsystemd not found])],
[*:yes],
AC_DEFINE([HAVE_LIBSYSTEMD], [1], [Define if libsystemd is available])
+ AC_DEFINE([HAVE_SYSTEMD], [1], [Define if systemd should be supported])
)
])
AM_CONDITIONAL([HAVE_SYSTEMD], [test "x$have_systemd" = xyes])