summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-02-18 15:06:49 +0100
committerKarel Zak2009-02-18 15:09:34 +0100
commit607c2a72952fc3c3e5014b447ba6b7d9f97b0ea1 (patch)
tree973758cdd662dfecea18502375c257ddb7018a24 /configure.ac
parentblkid: fix low-probe mode return codes (diff)
downloadkernel-qcow2-util-linux-607c2a72952fc3c3e5014b447ba6b7d9f97b0ea1.tar.gz
kernel-qcow2-util-linux-607c2a72952fc3c3e5014b447ba6b7d9f97b0ea1.tar.xz
kernel-qcow2-util-linux-607c2a72952fc3c3e5014b447ba6b7d9f97b0ea1.zip
fsck: move fsck from e2fsprogs to util-linux-ng
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e5e4a5b97..ac7d238cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,7 +79,9 @@ AC_CHECK_HEADERS(
linux/tiocl.h \
linux/version.h \
locale.h \
+ stdlib.h \
pty.h \
+ mntent.h \
rpcsvc/nfs_prot.h \
scsi/scsi.h \
stdlib.h \
@@ -205,7 +207,6 @@ AC_ARG_ENABLE([mount],
AS_HELP_STRING([--disable-mount], [do not build mount utilities]),
[], enable_mount=check
)
-
build_mount=yes
if test "${enable_mount}" = "no"; then
build_mount=no
@@ -217,10 +218,21 @@ else
AC_MSG_WARN([non-linux system; do not build mount utilities])
build_mount=no
fi
-
AM_CONDITIONAL(BUILD_MOUNT, test "x$build_mount" = xyes)
+AC_ARG_ENABLE([fsck],
+ AS_HELP_STRING([--enable-fsck], [do build fsck]),
+ [], enable_fsck=no
+)
+if test "x$enable_fsck" = xyes; then
+ if test "x$have_blkid" = xno && test "x$have_volume_id" = xno; then
+ AC_MSG_ERROR([libblkid or libvolume_id is needed to build util-linux-ng fsck])
+ fi
+fi
+AM_CONDITIONAL(BUILD_FSCK, test "x$enable_fsck" = xyes)
+
+
dnl UTIL_PKG_STATIC(VARIABLE, MODULES)
dnl ----------------------------------
AC_DEFUN([UTIL_PKG_STATIC], [
@@ -751,6 +763,7 @@ AC_CONFIG_FILES([
Makefile
disk-utils/Makefile
fdisk/Makefile
+fsck/Makefile
getopt/Makefile
hwclock/Makefile
include/Makefile