summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2007-07-11 12:37:40 +0200
committerKarel Zak2007-07-11 12:37:40 +0200
commit6a97809b9fc9bb4113e1ecfa95d68536b0a720a8 (patch)
tree9d83f809e2e9b1e096de03a878593c4c21efcc73 /configure.ac
parentwhereis: add lib64 paths (diff)
downloadkernel-qcow2-util-linux-6a97809b9fc9bb4113e1ecfa95d68536b0a720a8.tar.gz
kernel-qcow2-util-linux-6a97809b9fc9bb4113e1ecfa95d68536b0a720a8.tar.xz
kernel-qcow2-util-linux-6a97809b9fc9bb4113e1ecfa95d68536b0a720a8.zip
sys-utils: add arch(1) back to the official tree
This patch add arch(1) back to util-linux source code tree, but the command is not installed by defautl. For more details see "./configure --help". The arch command is deprecated in favor of "uname -m" (coreutils). The latest (6.9+) version of coreutils also supports arch(1) as an alias to "uname -a". Please, if you need arch(1) use the coreutils implementation. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0af567a07..c1c596505 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,6 +246,11 @@ UTIL_SET_ARCH(PPC, ppc*|powerpc*)
UTIL_SET_ARCH(M68K, m68*)
UTIL_SET_ARCH(MIPS, mips*)
+AC_ARG_ENABLE([arch],
+ AS_HELP_STRING([--enable-arch], [do build arch]),
+ [], enable_arch=no
+)
+AM_CONDITIONAL(BUILD_ARCH, test x$enable_arch = xyes)
AC_ARG_ENABLE([agetty],
AS_HELP_STRING([--disable-agetty], [do not build agetty]),
@@ -253,7 +258,6 @@ AC_ARG_ENABLE([agetty],
)
AM_CONDITIONAL(BUILD_AGETTY, test x$enable_agetty = xyes)
-
AC_ARG_ENABLE([cramfs],
AS_HELP_STRING([--disable-cramfs], [do not build fsck.cramfs, mkfs.cramfs]),
[], enable_cramfs=check