summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-04-10 22:57:27 +0200
committerKarel Zak2013-04-10 22:57:27 +0200
commit6acf31ac5c8bddaea304f94dfefe730f23bac89d (patch)
tree4d9da72f4dd5f3bab0ff497cdd2c5180c9008fed /configure.ac
parentbuild-sys: add --disable-bfs (diff)
downloadkernel-qcow2-util-linux-6acf31ac5c8bddaea304f94dfefe730f23bac89d.tar.gz
kernel-qcow2-util-linux-6acf31ac5c8bddaea304f94dfefe730f23bac89d.tar.xz
kernel-qcow2-util-linux-6acf31ac5c8bddaea304f94dfefe730f23bac89d.zip
build-sys: add --disable-hwclock
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e21b17cc2..84148abd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -966,9 +966,14 @@ UL_BUILD_INIT([bfs])
AM_CONDITIONAL(BUILD_BFS, test "x$build_bfs" = xyes)
-if test "x$have_io" = xyes -o "x$linux_os" = xyes; then
- build_hwclock=yes
-fi
+AC_ARG_ENABLE([hwclock],
+ AS_HELP_STRING([--disable-hwclock], [do not build hwclock]),
+ [], enable_hwclock=check
+)
+have_linuxdummy=$linux_os
+
+UL_BUILD_INIT([hwclock])
+UL_REQUIRES_HAVE([hwclock], [io, linuxdummy], [ioperm iopl function or Linux])
AM_CONDITIONAL(BUILD_HWCLOCK, test "x$build_hwclock" = xyes)