summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Bar-Lev2008-11-14 17:40:25 +0100
committerKarel Zak2008-11-19 12:40:06 +0100
commit7177d32ecfc2c1404e6067a573362af3324840fb (patch)
tree6b8f3c9f3ed30c28d9ebe49a0b09e3041eb6928a /configure.ac
parentpivot_root: clean up (diff)
downloadkernel-qcow2-util-linux-7177d32ecfc2c1404e6067a573362af3324840fb.tar.gz
kernel-qcow2-util-linux-7177d32ecfc2c1404e6067a573362af3324840fb.tar.xz
kernel-qcow2-util-linux-7177d32ecfc2c1404e6067a573362af3324840fb.zip
build-sys: add --disable-mount
I use busybox for most of the utilities, still lacks a few that I wish to use from util-linux... So mount comes from busybox. And during the cross compile I don't want to compile the mount dependencies only to make the configure script happy... Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 23 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 770eb45ae..3bbfd5736 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,20 +144,32 @@ AC_ARG_WITH([fsprobe],
[], [with_fsprobe=blkid]
)
+AC_ARG_ENABLE([mount],
+ AS_HELP_STRING([--disable-mount], [do not build mount utilities]),
+ [], enable_mount=check
+)
+
AM_CONDITIONAL(HAVE_BLKID, false)
AM_CONDITIONAL(HAVE_VOLUME_ID, false)
-
-have_blkid=no
-have_volume_id=no
-if test "x$with_fsprobe" = xblkid; then
- UTIL_CHECK_LIB(blkid, blkid_known_fstype)
-elif test "x$with_fsprobe" = xvolume_id; then
- UTIL_CHECK_LIB(volume_id, volume_id_encode_string)
-fi
-
-if test "x$have_blkid" = xno && test "x$have_volume_id" = xno; then
- AC_MSG_ERROR([blkid or volume_id is needed to build util-linux-ng.])
+if test "${enable_mount}" = "no"; then
+ build_mount=no
+elif test "x$linux_os" = xyes; then
+ build_mount=yes
+ have_blkid=no
+ have_volume_id=no
+ if test "x$with_fsprobe" = xblkid; then
+ UTIL_CHECK_LIB(blkid, blkid_known_fstype)
+ elif test "x$with_fsprobe" = xvolume_id; then
+ UTIL_CHECK_LIB(volume_id, volume_id_encode_string)
+ fi
+ if test "x$have_blkid" = xno && test "x$have_volume_id" = xno; then
+ AC_MSG_ERROR([blkid or volume_id is needed to build util-linux-ng mount utilities])
+ fi
+else
+ AC_MSG_WARN([non-linux system; do not build mount utilities])
+ build_mount=no
fi
+AM_CONDITIONAL(BUILD_MOUNT, test "x$build_mount" = xyes)
dnl UTIL_PKG_STATIC(VARIABLE, MODULES)
dnl ----------------------------------