summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-08-29 17:34:26 +0200
committerKarel Zak2012-09-04 17:00:31 +0200
commit7ec6adb1cc00719b10b21a732474fc444acaac95 (patch)
tree87e0d1910afdea7216f7b887fc3b79e4cea19687 /configure.ac
parentsu: move generic su code to su-common.c (diff)
downloadkernel-qcow2-util-linux-7ec6adb1cc00719b10b21a732474fc444acaac95.tar.gz
kernel-qcow2-util-linux-7ec6adb1cc00719b10b21a732474fc444acaac95.tar.xz
kernel-qcow2-util-linux-7ec6adb1cc00719b10b21a732474fc444acaac95.zip
runuser: new command (derived from su(1))
This command is based on su(1), the differences: - based on Fedora runuser su(1) patch - not installed with suid rights - allowed for root users only - don't ask for password - uses PAM session, for example: $ cat /etc/pam.d/runuser auth sufficient pam_rootok.so session optional pam_keyinit.so revoke session required pam_limits.so session required pam_unix.so $ cat /etc/pam.d/runuser-l auth include runuser session optional pam_keyinit.so force revoke session include runuser Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 54096dd95..ead559c30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1154,6 +1154,15 @@ UL_REQUIRES_HAVE([su], [security_pam_misc_h], [PAM header file])
AM_CONDITIONAL(BUILD_SU, test "x$build_su" = xyes)
+AC_ARG_ENABLE([runuser],
+ AS_HELP_STRING([--disable-runuser], [do not build runuser]),
+ [], enable_runuser=yes
+)
+UL_BUILD_INIT([runuser])
+UL_REQUIRES_HAVE([runuser], [security_pam_misc_h], [PAM header file])
+AM_CONDITIONAL(BUILD_RUNUSER, test "x$build_runuser" = xyes)
+
+
AC_ARG_ENABLE([schedutils],
AS_HELP_STRING([--disable-schedutils], [do not build chrt, ionice, teskset]),
[], enable_schedutils=yes