summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-02-11 09:42:49 +0100
committerKarel Zak2011-02-11 09:42:49 +0100
commit7f7126d749cb538547dd7bf85dc358f025ce6ea9 (patch)
treef841677f8a736efbd331314f75e0070dae9040e3 /configure.ac
parentpartx, lsblk: fix gettext calls (diff)
downloadkernel-qcow2-util-linux-7f7126d749cb538547dd7bf85dc358f025ce6ea9.tar.gz
kernel-qcow2-util-linux-7f7126d749cb538547dd7bf85dc358f025ce6ea9.tar.xz
kernel-qcow2-util-linux-7f7126d749cb538547dd7bf85dc358f025ce6ea9.zip
build-sys: don't build lsblk on Linux without openat()
Reported-by: Peter Breitenlohner <peb@mppmu.mpg.de> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f0e244b1a..ee3e71e90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -871,6 +871,15 @@ else
fi
AM_CONDITIONAL(BUILD_CRAMFS, test "x$build_cramfs" = xyes)
+build_lsblk=yes
+if test "x$have_openat" = xno; then
+ AC_MSG_WARN([openat() function not found; do not build lsblk])
+ build_lsblk=no
+elif test "x$have_linux" = xno; then
+ AC_MSG_WARN([non-linux system; do not build lsblk])
+ build_lsblk=no
+fi
+AM_CONDITIONAL(BUILD_LSBLK, test "x$build_lsblk" = xyes)
AC_ARG_ENABLE([switch_root],
AS_HELP_STRING([--disable-switch_root], [do not build switch_root]),