summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2014-09-17 10:56:46 +0200
committerKarel Zak2014-09-17 10:56:46 +0200
commit8026fa9bc7525c4cef02c17099e2db79284078f8 (patch)
tree9f2ad0175b170ace73daa5f5ca5b95a90d347b81 /configure.ac
parentipcrm: add hacks to avoid FTBFS (diff)
downloadkernel-qcow2-util-linux-8026fa9bc7525c4cef02c17099e2db79284078f8.tar.gz
kernel-qcow2-util-linux-8026fa9bc7525c4cef02c17099e2db79284078f8.tar.xz
kernel-qcow2-util-linux-8026fa9bc7525c4cef02c17099e2db79284078f8.zip
build-sys: use -lutil for BSD only
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5b558ec11..387372fd9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,9 +136,17 @@ PKG_PROG_PKG_CONFIG
GTK_DOC_CHECK([1.10])
AC_PATH_PROG([XSLTPROC], [xsltproc])
+
linux_os=no
-AS_CASE([${host_os}], [*linux*], [linux_os=yes])
+bsd_os=no
+AS_CASE([${host_os}],
+ [*linux*],
+ [linux_os=yes],
+ [*bsd*],
+ [bsd_os=yes])
AM_CONDITIONAL([LINUX], [test "x$linux_os" = xyes])
+AM_CONDITIONAL([BSD], [test "x$bsd_os" = xyes])
+
dnl define ARCH_<NAME> conditionals
UL_SET_ARCH([I86], [i?86-*])