summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2007-12-18 01:53:10 +0100
committerKarel Zak2008-01-03 21:47:29 +0100
commit8c182554153e7db8841bd5e663218d297df0b0f5 (patch)
treec13d88d34fbf6b697d3ba5359d8445ed3d0ae86a /configure.ac
parentswapon: add sundries.h (diff)
downloadkernel-qcow2-util-linux-8c182554153e7db8841bd5e663218d297df0b0f5.tar.gz
kernel-qcow2-util-linux-8c182554153e7db8841bd5e663218d297df0b0f5.tar.xz
kernel-qcow2-util-linux-8c182554153e7db8841bd5e663218d297df0b0f5.zip
build-sys: disable syscall fallbacks for non-linux systems
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index ca1c525f4..66bfa51c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,14 @@ esac
AC_PROG_CC_STDC
AC_GNU_SOURCE
+linux_os=no
+case ${host_os} in
+ *linux*)
+ linux_os=yes
+ ;;
+esac
+AM_CONDITIONAL([LINUX], test x$linux_os = xyes)
+
AC_PATH_PROG(PERL, perl)
AC_PATH_PROG(BLKID, blkid, [], [$PATH:/sbin])
AC_PATH_PROG(VOLID, vol_id, [], [$PATH:/lib/udev])
@@ -208,9 +216,11 @@ AC_DEFUN([UTIL_CHECK_SYSCALL], [
[syscall=_NR_$1],
[
syscall=no
- case $host_cpu in
- _UTIL_CHECK_SYSCALL_FALLBACK(m4_shift($@))
- esac
+ if test $linux_os = yes; then
+ case $host_cpu in
+ _UTIL_CHECK_SYSCALL_FALLBACK(m4_shift($@))
+ esac
+ fi
])
])
util_cv_syscall_$1=$syscall
@@ -294,14 +304,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
[AC_MSG_NOTICE([Your libc thinks that swapon has 1 arg only.])
])
-case ${host_os} in
- *linux*)
- AM_CONDITIONAL([LINUX], [true])
- ;;
- *)
- AM_CONDITIONAL([LINUX], [false])
- ;;
-esac
dnl UTIL_SET_ARCH(ARCHNAME, PATTERN)
dnl ---------------------------------