summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Henriksson2017-07-27 16:00:42 +0200
committerKarel Zak2017-07-31 15:24:46 +0200
commit8df545592d73b67b0bf119732b52a5e4c0662ec4 (patch)
tree5a180a226121dce8f51c8653ebdf4b8a1e0f90fe /configure.ac
parentwhereis: include native multiarch path in lib search paths (diff)
downloadkernel-qcow2-util-linux-8df545592d73b67b0bf119732b52a5e4c0662ec4.tar.gz
kernel-qcow2-util-linux-8df545592d73b67b0bf119732b52a5e4c0662ec4.tar.xz
kernel-qcow2-util-linux-8df545592d73b67b0bf119732b52a5e4c0662ec4.zip
build: use --runstatedir instead of --localstatedir
The util-linux code was previously aligned to use @localstatedir@ and the util-linux build system was set to override the default to use /run. Current GNU Coding Standards introduced the @runstatedir@ variable for this purpose. Lets use that instead. The GNU default for @runstatedir@ is ${localstatedir}/run so util-linux still override the default to be /run to preserve the status quo from before. The only difference is that you'll now pass --runstatedir to override the location on the command line instead of --localstatedir. (FWIW, Debhelper in compat 11 will automatically start passing --runstatedir=/run to all autotools configured builds. It already passes --localstatedir=/var (to avoid it ending up with the GNU default /usr/local/var) which breaks the util-linux build system code that tries to default it to /run. This change will thus allow util-linux and debhelper to work better together and avoid the need for a package-specific override.) Relevant historic commits: * commit 07a16b9d1e5a48550a0d19abb9a900853433ffa2 "build-sys: change --localstatedir to /run" * commit 80c51185d50f00a2701f9379f10fc48a0f885dfc "uuidd: use run configured state directory" * commit 01c5b787947aeaffc7e56000827e3edefa357c59 "agetty: use configured run state directory" [kzak@redhat.com: - add $runstatedir fallback for autoconf < 2.70 - check for unmodified $localstatedir] CC: Sami Kerola <kerolasa@iki.fi> Signed-off-by: Andreas Henriksson <andreas@fatal.se> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index dc71faa00..b204ec11e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,13 +72,17 @@ AS_CASE([$exec_prefix:$prefix],
]
)
-AS_CASE([$prefix:$localstatedir],
- [NONE:'${prefix}/var' | /usr:'${prefix}/var'],
- [localstatedir=/run
- AC_MSG_NOTICE([ --localstatedir defaults to /run])
- ]
+
+# default for old versions without $runstatedir
+AS_IF([test x"$runstatedir" = x], [runstatedir='${localstatedir}/run'])
+
+# our default if $localstatedir unchanged
+AS_CASE([$localstatedir:$runstatedir],
+ [NONE:'${localstatedir}/run' | /var:'${localstatedir}/run' | NONE:'/run' ],
+ [runstatedir=/run; AC_MSG_NOTICE([ --runstatedir defaults to /run])]
)
-AC_SUBST([localstatedir])
+
+AC_SUBST([runstatedir])
# The original default values of {bin,sbin,lib}dir
@@ -2282,7 +2286,7 @@ AC_MSG_RESULT([
prefix: ${prefix}
exec prefix: ${exec_prefix}
- localstatedir: ${localstatedir}
+ runstatedir: ${runstatedir}
bindir: ${bindir}
sbindir: ${sbindir}
libdir: ${libdir}