summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola2013-08-26 14:11:44 +0200
committerSami Kerola2013-08-29 19:14:06 +0200
commit918785dd1fce01cccbe200b23cdc4d6115a2fc82 (patch)
tree382653bea1c63dbd0280f22c4a3cab00b30458c1 /configure.ac
parentsu: suppress PAM info messages for -c or non-login sessions (diff)
downloadkernel-qcow2-util-linux-918785dd1fce01cccbe200b23cdc4d6115a2fc82.tar.gz
kernel-qcow2-util-linux-918785dd1fce01cccbe200b23cdc4d6115a2fc82.tar.xz
kernel-qcow2-util-linux-918785dd1fce01cccbe200b23cdc4d6115a2fc82.zip
build-sys: pylibmount will not work when python3 is present
While compiling with up to date Archlinux I notice the recently added pylibmount does not link correctly. Failures inform fundamental types such as PyFileObject and PyFile_Type being missing. It seems automake AM_PATH_PYTHON will prefer the python in path, which for this distribution right now is python3. As some sort of go-around one can install older python, and symlink it to earlier in PATH lookup. $ ln -s /usr/bin/python2 $HOME/bin/python $ export PATH=$HOME/bin:$PATH Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a0a72fd29..d24ed8f7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1387,6 +1387,12 @@ AS_IF([test "x$with_python" = xyes], [
])
])
+dnl FIXME: the python3 should be fixed in future.
+AS_CASE([$PYTHON_VERSION],
+ [2.*], [],
+ [3.*], [AC_MSG_ERROR([pylibmount will not work with python3])],
+ [AC_MSG_ERROR([unanticipated python version])]
+)
UL_BUILD_INIT([pylibmount], [check])
UL_REQUIRES_HAVE([pylibmount], [python])