summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-28 00:23:59 +0200
committerKarel Zak2011-11-03 12:32:51 +0100
commit945ac25080493126d094731510b85bc2d90a1170 (patch)
tree15e92f972f9b46aff984477bebaf5e89eb284561 /configure.ac
parentlibuuid: fix includes in man pages (diff)
downloadkernel-qcow2-util-linux-945ac25080493126d094731510b85bc2d90a1170.tar.gz
kernel-qcow2-util-linux-945ac25080493126d094731510b85bc2d90a1170.tar.xz
kernel-qcow2-util-linux-945ac25080493126d094731510b85bc2d90a1170.zip
prlimit: add add falbacks
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 36dffc727..49de07d98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -854,6 +854,15 @@ UL_REQUIRES_HAVE([chcpu], [cpu_set_t], [cpu_set_t type])
AM_CONDITIONAL(BUILD_CHCPU, test "x$build_chcpu" = xyes)
+UL_BUILD_INIT([prlimit], [check])
+UL_REQUIRES_LINUX([prlimit])
+UL_REQUIRES_SYSCALL_CHECK([prlimit], [UL_CHECK_SYSCALL([prlimit64])], [prlimit64])
+AM_CONDITIONAL(BUILD_PRLIMIT, test "x$build_prlimit" = xyes)
+if test "x$build_prlimit" = xyes; then
+ AC_CHECK_FUNCS([prlimit])
+fi
+
+
AC_ARG_ENABLE([switch_root],
AS_HELP_STRING([--disable-switch_root], [do not build switch_root]),
[], enable_switch_root=check