summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2010-07-01 10:43:06 +0200
committerKarel Zak2010-07-01 10:43:06 +0200
commit965b4900b9d0a0d716273558e52e188820108709 (patch)
tree5b45f21f3a6a24236624568bba744ba1220b2fe8 /configure.ac
parenttests: truncate BeFS and tuxonice images (diff)
downloadkernel-qcow2-util-linux-965b4900b9d0a0d716273558e52e188820108709.tar.gz
kernel-qcow2-util-linux-965b4900b9d0a0d716273558e52e188820108709.tar.xz
kernel-qcow2-util-linux-965b4900b9d0a0d716273558e52e188820108709.zip
build-sys: explicitly check for slang.h
The slang/slcurses.h contains #includes <slang.h> but we don't use -I/usr/include/slang (and this is also missing in slang.pc), it means that we have manually include the slang.h file in our configure script. Note this is Fedora-12, maybe some others distros have more usable slang headers... Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7aff91676..8c5f92f42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -470,7 +470,15 @@ AM_CONDITIONAL(HAVE_TINFO, test "x$have_tinfo" = xyes)
use_slang=no
if test "x$with_slang" = xyes; then
- AC_CHECK_HEADERS([slcurses.h slang/slcurses.h], [use_slang=yes])
+ AC_CHECK_HEADERS([slang.h slang/slang.h])
+ AC_CHECK_HEADERS([slcurses.h slang/slcurses.h],
+ [use_slang=yes], [], [
+#ifdef HAVE_SLANG_H
+#include <slang.h>
+#elif defined(HAVE_SLANG_SLANG_H)
+#include <slang/slang.h>
+#endif
+])
if test "x$use_slang" = xno; then
AC_MSG_ERROR([slang selected but slcurses.h not found])
fi