summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2018-10-24 12:18:54 +0200
committerKarel Zak2018-12-03 11:23:33 +0100
commit9a558f9cf68f89f62799b073d0fe7fcdd7aafdba (patch)
treedc34c97b6150b2e084c31b85a0b5682761f1b905 /configure.ac
parentinclude/c: re-add type checking in container_of() (diff)
downloadkernel-qcow2-util-linux-9a558f9cf68f89f62799b073d0fe7fcdd7aafdba.tar.gz
kernel-qcow2-util-linux-9a558f9cf68f89f62799b073d0fe7fcdd7aafdba.tar.xz
kernel-qcow2-util-linux-9a558f9cf68f89f62799b073d0fe7fcdd7aafdba.zip
build-sys: make sure HAVE_TIMER_CREATE defined
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6ed505de5..21b04f581 100644
--- a/configure.ac
+++ b/configure.ac
@@ -544,14 +544,16 @@ AC_CHECK_FUNCS([timer_create],
[AC_CHECK_LIB([rt], [timer_create], [
have_timer="yes"
REALTIME_LIBS="-lrt"
+ AC_DEFINE_UNQUOTED([HAVE_TIMER_CREATE], [1], [Define if timer_create exist in -lrt])
],[
AC_SEARCH_LIBS([timer_create], [rt], [
AC_MSG_RESULT(yes)
have_timer="yes"
REALTIME_LIBS="-lrt -lpthread"
+ AC_DEFINE_UNQUOTED([HAVE_TIMER_CREATE], [1], [Define if timer_create exist in -lrt -lpthread])
],[], [-lpthread]
)
- ])]
+ ])]
)
AC_SUBST([REALTIME_LIBS])