summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola2013-03-19 23:24:41 +0100
committerSami Kerola2013-03-30 11:17:49 +0100
commit9cc36e9fdf24a67cc7a7d186a39cbf8398ba9d37 (patch)
tree8138dc19d94ace700c90886ec94c6511b01b5208 /configure.ac
parentlsblk: add --paths (diff)
downloadkernel-qcow2-util-linux-9cc36e9fdf24a67cc7a7d186a39cbf8398ba9d37.tar.gz
kernel-qcow2-util-linux-9cc36e9fdf24a67cc7a7d186a39cbf8398ba9d37.tar.xz
kernel-qcow2-util-linux-9cc36e9fdf24a67cc7a7d186a39cbf8398ba9d37.zip
bash-completion: add bash completetion configure option
Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92a5a3b12..cd4e826a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1342,6 +1342,18 @@ fi
AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != "xno" ])
+AC_ARG_WITH([bashcompletiondir],
+ AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),
+ [],
+ [AS_IF([$($PKG_CONFIG --exists bash-completion)], [
+ with_bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
+ ], [
+ with_bashcompletiondir=${datadir}/bash-completion/completions
+ ])
+])
+AC_SUBST([bashcompletiondir], [$with_bashcompletiondir])
+
+
AC_ARG_ENABLE([pg-bell],
AS_HELP_STRING([--disable-pg-bell], [let pg not ring the bell on invalid keys]),
[], enable_pg_bell=yes
@@ -1463,6 +1475,7 @@ AC_MSG_RESULT([
suid cflags: ${SUID_CFLAGS}
ldflags: ${LDFLAGS}
suid ldflags: ${SUID_LDFLAGS}
+ Bash completions dir: ${with_bashcompletiondir}
warnings: