summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2007-07-18 10:46:42 +0200
committerKarel Zak2007-07-18 10:46:42 +0200
commit9dc801d2b7073004679c4dc3f7a60b623bbfcbd5 (patch)
treed0265cbafcd6f08e79d577eb21f03e4d24b0622c /configure.ac
parentbuild-sys: release++ (diff)
downloadkernel-qcow2-util-linux-9dc801d2b7073004679c4dc3f7a60b623bbfcbd5.tar.gz
kernel-qcow2-util-linux-9dc801d2b7073004679c4dc3f7a60b623bbfcbd5.tar.xz
kernel-qcow2-util-linux-9dc801d2b7073004679c4dc3f7a60b623bbfcbd5.zip
build-sys: add warning when libuuid is not found
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 35852f867..270587322 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,7 +69,12 @@ AC_DEFUN([UTIL_CHECK_LIB], [
AC_CHECK_LIB([$1], [$2], [], [have_$1=no])
AM_CONDITIONAL(AS_TR_CPP(HAVE_$1), [test $have_$1 = yes])
])
+
UTIL_CHECK_LIB(uuid, uuid_is_null)
+if test $have_uuid = no; then
+ AC_MSG_WARN([uuid library is not found; mkswap(8) will not generate UUIDs])
+fi
+
UTIL_CHECK_LIB(util, openpty)
UTIL_CHECK_LIB(termcap, tgetnum)