summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-27 14:20:35 +0200
committerKarel Zak2011-11-03 12:32:49 +0100
commita13cdb7a2d493777588dd98ba4c7ad4f280319c0 (patch)
tree7091e20b3c82a7ac30e01cff50757c198598b501 /configure.ac
parentbuild-sys: cleanup BUILD_UUIDD (diff)
downloadkernel-qcow2-util-linux-a13cdb7a2d493777588dd98ba4c7ad4f280319c0.tar.gz
kernel-qcow2-util-linux-a13cdb7a2d493777588dd98ba4c7ad4f280319c0.tar.xz
kernel-qcow2-util-linux-a13cdb7a2d493777588dd98ba4c7ad4f280319c0.zip
build-sys: cleanup BUILD_LSBLK
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 984ad597d..276a6ef35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -794,16 +794,14 @@ else
fi
AM_CONDITIONAL(BUILD_CRAMFS, test "x$build_cramfs" = xyes)
+
+enable_lsblk=check
build_lsblk=yes
-if test "x$have_openat" = xno; then
- AC_MSG_WARN([openat() function not found; do not build lsblk])
- build_lsblk=no
-elif test "x$linux_os" = xno; then
- AC_MSG_WARN([non-linux system; do not build lsblk])
- build_lsblk=no
-fi
+UL_REQUIRES_LINUX([lsblk])
+UL_REQUIRES_BUILD([lsblk], [libblkid])
AM_CONDITIONAL(BUILD_LSBLK, test "x$build_lsblk" = xyes)
+
AC_ARG_ENABLE([switch_root],
AS_HELP_STRING([--disable-switch_root], [do not build switch_root]),
[], enable_switch_root=check