summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Forney2013-10-03 11:39:18 +0200
committerKarel Zak2013-10-04 11:51:34 +0200
commitb09bc5088bed5174f1ffa3d4a51cef1cdd37292f (patch)
treeff29a6429b3609e261e1cc56a3388a200092b9bf /configure.ac
parentinclude: Add missing includes (diff)
downloadkernel-qcow2-util-linux-b09bc5088bed5174f1ffa3d4a51cef1cdd37292f.tar.gz
kernel-qcow2-util-linux-b09bc5088bed5174f1ffa3d4a51cef1cdd37292f.tar.xz
kernel-qcow2-util-linux-b09bc5088bed5174f1ffa3d4a51cef1cdd37292f.zip
build-sys: Check for type sighandler_t and use if present
__sighandler_t is libc implementation specific and should not be relied upon. Instead, we fall back upon void (*)(int), as specified by POSIX. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 12d0babf7..93572fe8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -497,6 +497,10 @@ AC_CHECK_TYPES([cpu_set_t], [have_cpu_set_t=yes], [], [[
AM_CONDITIONAL([HAVE_CPU_SET_T], [test "x$have_cpu_set_t" = xyes])
+AC_CHECK_TYPES([sighandler_t], [], [], [[
+#include <signal.h>
+]])
+
AC_CHECK_DECLS([CPU_ALLOC], [], [], [[
#include <sched.h>
]])