summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-03-17 14:54:22 +0100
committerKarel Zak2009-03-17 15:54:30 +0100
commitb0a0d7d58f397f45a27ee3e876800989992096d1 (patch)
tree83a27d50796534b9c21cc09e017aad52b6072353 /configure.ac
parentinclude: bitops - explicitly include endian.h (diff)
downloadkernel-qcow2-util-linux-b0a0d7d58f397f45a27ee3e876800989992096d1.tar.gz
kernel-qcow2-util-linux-b0a0d7d58f397f45a27ee3e876800989992096d1.tar.xz
kernel-qcow2-util-linux-b0a0d7d58f397f45a27ee3e876800989992096d1.zip
build-sys: add $usrlibexecdir and fix paths for [/usr]/lib64
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a4f13d068..5612f4b4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,6 @@ BLKID_DATE="10-Feb-2009"
BLKID_VERSION=$BLKID_VERSION_MAJOR.$BLKID_VERSION_MINOR.$BLKID_VERSION_RELEASE
BLKID_VERSION_INFO=`expr $BLKID_VERSION_MAJOR + $BLKID_VERSION_MINOR`:$BLKID_VERSION_RELEASE:$BLKID_VERSION_MINOR
-
# Check whether exec_prefix=/usr:
case $exec_prefix:$prefix in
NONE:NONE | NONE:/usr | /usr:*)
@@ -41,6 +40,13 @@ NONE:NONE | NONE:/usr | /usr:*)
esac ;;
esac
+# lib64
+case ${libdir} in
+ *lib64) libdirname=lib64 ;;
+ *) libdirname=lib
+esac
+AC_SUBST([libdirname])
+
AC_PROG_CC_STDC
AC_GNU_SOURCE
AC_CANONICAL_HOST