summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2015-11-04 16:02:44 +0100
committerKarel Zak2015-11-04 17:19:41 +0100
commitb0e6b25e64e1c4cc4b7a67461a4b46fa32d480c0 (patch)
tree06929ab5e8879fe0fc7aa87f3456e78548fae239 /configure.ac
parentlib/sysfs: make sysfs_get_devname()/blkid_devno_to_wholedisk() more robust (diff)
downloadkernel-qcow2-util-linux-b0e6b25e64e1c4cc4b7a67461a4b46fa32d480c0.tar.gz
kernel-qcow2-util-linux-b0e6b25e64e1c4cc4b7a67461a4b46fa32d480c0.tar.xz
kernel-qcow2-util-linux-b0e6b25e64e1c4cc4b7a67461a4b46fa32d480c0.zip
build-sys: bump also PACKAGE_VERSION_RELEASE number
Now we bump only PACKAGE_VERSION_MAJOR and PACKAGE_VERSION_MINOR numbers. The PACKAGE_VERSION_RELEASE is always zero. These numbers are used for LIBxxx_VERSION strings and Version: field in the .pc files. Unfortunately, if we keep PACKAGE_VERSION_RELEASE= always zero then our bugfix releases are invisible for pkg-config. (Although I don't think it's good idea to depend in code on any library bugfix release, code should be about APIs). Addresses: https://github.com/systemd/systemd/pull/1754 Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 56512c036..6748dd2a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@ AC_INIT([util-linux],
[kzak@redhat.com],,
[http://www.kernel.org/pub/linux/utils/util-linux/])
+
AC_PREREQ([2.60])
AC_CONFIG_AUX_DIR([config])
@@ -22,7 +23,10 @@ dnl version details from <major>.<minor>[-<suffix>]
PACKAGE_VERSION_MAJOR=$(echo $PACKAGE_VERSION | awk -F. '{print $1}')
PACKAGE_VERSION_MINOR=$(echo $PACKAGE_VERSION | awk -F. '{print $2}' \
| awk -F- '{print $1}')
-PACKAGE_VERSION_RELEASE=0
+
+PACKAGE_VERSION_RELEASE=$(echo $PACKAGE_VERSION | awk -F. '{print $3}' \
+ | sed 's/.*@<:@^@<:@:digit:@:>@@:>@.*/0/')
+
dnl libblkid version
LIBBLKID_VERSION="$PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_RELEASE"