summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-02-13 10:54:24 +0100
committerKarel Zak2009-02-13 11:37:00 +0100
commitb12991dd5c4f8294096723158b6d387fc3d27342 (patch)
tree1db72f944ffcd2e6bb494c65a43d034b29779192 /configure.ac
parentblkid: start to use ABI versioning (diff)
downloadkernel-qcow2-util-linux-b12991dd5c4f8294096723158b6d387fc3d27342.tar.gz
kernel-qcow2-util-linux-b12991dd5c4f8294096723158b6d387fc3d27342.tar.xz
kernel-qcow2-util-linux-b12991dd5c4f8294096723158b6d387fc3d27342.zip
build-sys: libtoolize by libtool-2
We need an infrastructure for stared libraries. The latest libtool-2 seems useful and it's definitely better than the old 1.5 crap. You need to install libtool-2 when you want to run ./autogen.sh script after checkout from git repository. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dc8374de0..4ca1f112d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@ AC_INIT(util-linux-ng, 2.14, kzak@redhat.com)
AC_PREREQ(2.60)
AC_CONFIG_AUX_DIR(config)
+AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([check-news -Wall foreign 1.9 dist-bzip2])
@@ -19,11 +20,13 @@ BLKID_VERSION_RELEASE=0
BLKID_DATE="10-Feb-2009"
BLKID_VERSION=$BLKID_VERSION_MAJOR.$BLKID_VERSION_MINOR.$BLKID_VERSION_RELEASE
+BLKID_VERSION_INFO=`expr $BLKID_VERSION_MAJOR + $BLKID_VERSION_MINOR`:$BLKID_VERSION_RELEASE:$BLKID_VERSION_MINOR
AC_SUBST(BLKID_VERSION_MAJOR)
AC_SUBST(BLKID_VERSION_MINOR)
AC_SUBST(BLKID_VERSION_RELEASE)
AC_SUBST(BLKID_VERSION)
+AC_SUBST(BLKID_VERSION_INFO)
AC_DEFINE_UNQUOTED(BLKID_VERSION, "$BLKID_VERSION", [libblkid version string])
AC_DEFINE_UNQUOTED(BLKID_DATE, "$BLKID_DATE", [libblkid date string])
@@ -50,7 +53,9 @@ AC_PROG_CC_STDC
AC_GNU_SOURCE
AC_CANONICAL_HOST
AC_C_BIGENDIAN
-AC_PROG_RANLIB
+
+dnl libtool-2
+LT_INIT
linux_os=no
case ${host_os} in