summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-11-12 15:07:12 +0100
committerKarel Zak2013-11-12 15:07:12 +0100
commitb8095d25bae0588dfce8a62169f6db5496cf45c5 (patch)
tree5ea737db64009a3b633fdadc76b3d88ce97a3025 /configure.ac
parentsulogin: use dirent->d_type when scans /dev (diff)
downloadkernel-qcow2-util-linux-b8095d25bae0588dfce8a62169f6db5496cf45c5.tar.gz
kernel-qcow2-util-linux-b8095d25bae0588dfce8a62169f6db5496cf45c5.tar.xz
kernel-qcow2-util-linux-b8095d25bae0588dfce8a62169f6db5496cf45c5.zip
libmount: remove smackfs* option when SMACK not enabled
If there is no /sys/fs/smackfs then libmount removes smackfs*= mount options when compiled --with-smack. Note that we do the same for SELinux. References: http://www.mail-archive.com/systemd-devel@lists.freedesktop.org/msg13740.html Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53c0de2f0..8665780f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1407,6 +1407,15 @@ AS_IF([test "x$with_systemdsystemunitdir" != "xno"], [
AM_CONDITIONAL([HAVE_SYSTEMD], [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != "xno" ])
+AC_ARG_WITH([smack],
+ AS_HELP_STRING([--with-smack], [build with SMACK support]),
+ [], [with_smack=no]
+)
+AS_IF([test "x$with_smack" = xyes], [
+ AC_DEFINE([HAVE_SMACK], [1], [Add SMACK support])
+])
+
+
AC_ARG_WITH([bashcompletiondir],
AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),
[],