summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-05-31 10:03:35 +0200
committerKarel Zak2012-06-26 20:48:22 +0200
commitbafe1a75a326646083d2b653578f218531bdc0b8 (patch)
tree9325a72108cdec5db21aaafb20e93c643171a317 /configure.ac
parentbuild-sys: add UL_CONFLICTS_BUILD m4 macro (diff)
downloadkernel-qcow2-util-linux-bafe1a75a326646083d2b653578f218531bdc0b8.tar.gz
kernel-qcow2-util-linux-bafe1a75a326646083d2b653578f218531bdc0b8.tar.xz
kernel-qcow2-util-linux-bafe1a75a326646083d2b653578f218531bdc0b8.zip
build-sys: cleanup mount stuff in configure.am
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 10 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index adb5758e5..3bbc374ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -730,27 +730,25 @@ UL_REQUIRES_BUILD([deprecated_mount], [libblkid])
AM_CONDITIONAL(BUILD_DEPRECATED_MOUNT, test "x$build_deprecated_mount" = xyes)
-AC_ARG_ENABLE([losetup],
- AS_HELP_STRING([--disable-losetup], [do not build losetup]),
- [], enable_losetup=check
-)
-UL_BUILD_INIT([losetup])
-UL_REQUIRES_LINUX([losetup])
-AM_CONDITIONAL(BUILD_LOSETUP, test "x$build_losetup" = xyes)
-
-
AC_ARG_ENABLE([mount],
AS_HELP_STRING([--disable-mount], [do not build mount(8) and umount(8)]),
[], enable_mount=check
)
UL_BUILD_INIT([mount])
UL_REQUIRES_BUILD([mount], [libmount])
-if test "x$build_mount" = xyes; then
- AM_CONDITIONAL(BUILD_DEPRECATED_MOUNT, [false])
-fi
+UL_CONFLICTS_BUILD([mount], [deprecated_mount], [old deprecated mount version])
AM_CONDITIONAL(BUILD_MOUNT, test "x$build_mount" = xyes)
+AC_ARG_ENABLE([losetup],
+ AS_HELP_STRING([--disable-losetup], [do not build losetup]),
+ [], enable_losetup=check
+)
+UL_BUILD_INIT([losetup])
+UL_REQUIRES_LINUX([losetup])
+AM_CONDITIONAL(BUILD_LOSETUP, test "x$build_losetup" = xyes)
+
+
AC_ARG_ENABLE([fsck],
AS_HELP_STRING([--disable-fsck], [do not build fsck]),
[], enable_fsck=check