summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2007-03-12 12:20:54 +0100
committerKarel Zak2007-03-12 12:20:54 +0100
commitbbae9cb03e90eb7d10e0bd6a6e3a6d21486c153f (patch)
tree16d0a458ab421f31bd61e0cc4c055e9a34822cd6 /configure.ac
parentlogin: add IPv6 support (diff)
downloadkernel-qcow2-util-linux-bbae9cb03e90eb7d10e0bd6a6e3a6d21486c153f.tar.gz
kernel-qcow2-util-linux-bbae9cb03e90eb7d10e0bd6a6e3a6d21486c153f.tar.xz
kernel-qcow2-util-linux-bbae9cb03e90eb7d10e0bd6a6e3a6d21486c153f.zip
build-sys: add support for audit
You can compile --with-audit now. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ccd05b361..95690ddf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -302,6 +302,19 @@ fi
AM_CONDITIONAL(HAVE_SELINUX, test x$ac_cv_lib_selinux_getprevcon = xyes)
+AC_ARG_WITH([audit],
+ AC_HELP_STRING([--with-audit], [compile with audit support]),
+ with_audit=$withval, with_audit=no
+)
+
+if test x$with_audit != xno; then
+ AC_CHECK_LIB(audit, audit_log_user_message)
+ if test x$with_audit = xyes && test x$ac_cv_lib_audit_audit_log_user_message = xno; then
+ AC_MSG_ERROR([Audit selected but libaudit not found (or doesn't support audit_log_user_message())])
+ fi
+fi
+AM_CONDITIONAL(HAVE_AUDIT, test x$ac_cv_lib_audit_audit_log_user_message = xyes)
+
AC_ARG_ENABLE([schedutils],
AC_HELP_STRING([--disable-schedutils], [do not build chrt, ionice, teskset]),