summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Uzel2012-05-03 21:01:54 +0200
committerKarel Zak2012-05-04 15:14:04 +0200
commitbbe289c4895ed37727be8291c9a7ec1f1e247657 (patch)
treeca1af59813aeaa3df65b5f37ad675a138242d27c /configure.ac
parentuuidd: factor out socket creation into separate function (diff)
downloadkernel-qcow2-util-linux-bbe289c4895ed37727be8291c9a7ec1f1e247657.tar.gz
kernel-qcow2-util-linux-bbe289c4895ed37727be8291c9a7ec1f1e247657.tar.xz
kernel-qcow2-util-linux-bbe289c4895ed37727be8291c9a7ec1f1e247657.zip
uuidd: implement --socket-activation option
Implement --socket-activation option, which is supposed to be used with systemd (or equivalent init system) socket activation mechanism. With this option, the UUID daemon does not create the socket on its own, but instead expect the connection fd to be provided by the calling process. This option is only available if util-linux is configured with --enable-socket-activation option. With this configure option, the uuidd is compiled with sd-daemon.c. Signed-off-by: Petr Uzel <petr.uzel@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b5f3d5700..8b80f388f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1131,6 +1131,18 @@ if test "x$enable_login_chown_vcs" = xyes; then
fi
+AC_ARG_ENABLE([socket-activation],
+ AS_HELP_STRING([--enable-socket-activation], [build uuidd with support for systemd socket activation]),
+ [], enable_socket_activation=no
+)
+
+AM_CONDITIONAL(USE_SOCKET_ACTIVATION, test "x$enable_socket_activation" = xyes)
+
+if test "x$enable_socket_activation" = xyes; then
+ AC_DEFINE(USE_SOCKET_ACTIVATION, 1, [Should uuidd support socket activation?])
+fi
+
+
AC_ARG_ENABLE([login-stat-mail],
AS_HELP_STRING([--enable-login-stat-mail], [let login stat() the mailbox]),
[], enable_login_stat_mail=no