summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-06-09 10:15:28 +0200
committerKarel Zak2009-06-22 21:30:46 +0200
commitbd6713471f125eafbd6dd464414b4787e4c8f6fc (patch)
treeb05c27dc9012ec732d56b575fe3dc46fc742ff6c /configure.ac
parentswitch_root: new command (diff)
downloadkernel-qcow2-util-linux-bd6713471f125eafbd6dd464414b4787e4c8f6fc.tar.gz
kernel-qcow2-util-linux-bd6713471f125eafbd6dd464414b4787e4c8f6fc.tar.xz
kernel-qcow2-util-linux-bd6713471f125eafbd6dd464414b4787e4c8f6fc.zip
build-sys: add --disable-switch_root
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f700f5781..ac5fecd6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -628,6 +628,13 @@ fi
AM_CONDITIONAL(BUILD_CRAMFS, test "x$build_cramfs" = xyes)
+AC_ARG_ENABLE([switch_root],
+ AS_HELP_STRING([--disable-switch_root], [do not build switch_root]),
+ [], enable_switch_root=no
+)
+AM_CONDITIONAL(BUILD_SWITCH_ROOT, test "x$enable_switch_root" = xyes)
+
+
AC_ARG_ENABLE([elvtune],
AS_HELP_STRING([--enable-elvtune], [build elvtune (only works with 2.2 and 2.4 kernels)]),
[], enable_elvtune=no