summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-12-20 13:07:54 +0100
committerKarel Zak2011-12-20 13:07:54 +0100
commitbd6d0d039c311b4f31f1c2a1312ff414dfbd020a (patch)
treeb362c3559c370e34b7b0463c7a088ecb326898e7 /configure.ac
parentlosetup: remove mount-specific headers (diff)
downloadkernel-qcow2-util-linux-bd6d0d039c311b4f31f1c2a1312ff414dfbd020a.tar.gz
kernel-qcow2-util-linux-bd6d0d039c311b4f31f1c2a1312ff414dfbd020a.tar.xz
kernel-qcow2-util-linux-bd6d0d039c311b4f31f1c2a1312ff414dfbd020a.zip
losetup: move to sys-utils directory
Now losetup(8) is independent on mount/ stuff at all. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0d61acee..aa4af0880 100644
--- a/configure.ac
+++ b/configure.ac
@@ -687,6 +687,15 @@ UL_REQUIRES_BUILD([mount], [libblkid])
AM_CONDITIONAL(BUILD_MOUNT, test "x$build_mount" = xyes)
+AC_ARG_ENABLE([losetup],
+ AS_HELP_STRING([--disable-losetup], [do not build losetup]),
+ [], enable_losetup=check
+)
+UL_BUILD_INIT([losetup])
+UL_REQUIRES_LINUX([losetup])
+AM_CONDITIONAL(BUILD_LOSETUP, test "x$build_losetup" = xyes)
+
+
AC_ARG_ENABLE([libmount-mount],
AS_HELP_STRING([--enable-libmount-mount], [link mount(8) with libmount (EXPERIMENTAL)]),
[], enable_libmount_mount=no