summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSukadev Bhattiprolu2015-11-25 21:10:39 +0100
committerKarel Zak2015-12-02 11:33:58 +0100
commitbd9b94d12a6158b6080630085f77e59ac1b7de26 (patch)
tree0587821cdfe45cdc6311ff5eca6ef5b6a6b9181f /configure.ac
parentMerge branch 'races' of git://github.com/kerolasa/lelux-utiliteetit (diff)
downloadkernel-qcow2-util-linux-bd9b94d12a6158b6080630085f77e59ac1b7de26.tar.gz
kernel-qcow2-util-linux-bd9b94d12a6158b6080630085f77e59ac1b7de26.tar.xz
kernel-qcow2-util-linux-bd9b94d12a6158b6080630085f77e59ac1b7de26.zip
lscpu: Print physical cpu information
lscpu currently prints information for CPUs configured in the system. In case of KVM or other virtualized guest operating systems, this refers to the virtual system, and bears no relation to the physical topology of the system. It would be useful if lscpu could also display the physical topology info when available: $ ./lscpu Architecture: ppc64le Byte Order: Little Endian CPU(s): 16 On-line CPU(s) list: 0-15 Thread(s) per core: 1 Core(s) per socket: 1 Socket(s): 16 NUMA node(s): 1 Model: IBM pSeries (emulated by qemu) Hypervisor vendor: KVM Virtualization type: para L1d cache: 64K L1i cache: 32K NUMA node0 CPU(s): 0-15 Physical sockets: 2 <<< New Physical chips: 4 <<< New Physical cores/chip: 4 <<< New For now, physical topology information is available on platforms that support the following RTAS (Real time abstraction service) call provided by librtas: rtas_get_sysparm(PROCESSOR_MODULE_INFO). Currently this call is available to the PowerVM (pHYP) guests on PowerPC. With a patch propoosed to PowerKVM, this RTAS call would also be available to PowerKVM guests. Based on input from Nishanth Aravamudan and Karel Zak. Signed-off-by: Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90d08f39e..0748fb1c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -386,6 +386,12 @@ AC_CHECK_FUNCS([clock_gettime], [],
)
AC_SUBST([REALTIME_LIBS])
+AC_CHECK_LIB([rtas], [rtas_get_sysparm], [
+ RTAS_LIBS="-lrtas"
+ AC_DEFINE_UNQUOTED([HAVE_LIBRTAS], [1], [Define if librtas exists]), [],
+])
+AC_SUBST([RTAS_LIBS])
+
have_timer="no"
AC_CHECK_FUNCS([timer_createx],
[have_time="yes"],