summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRuediger Meier2016-11-17 03:09:58 +0100
committerKarel Zak2016-11-29 10:47:11 +0100
commitc42a6d4d340b2f829369eae19ec2d888d33cb433 (patch)
tree55a744e404c2ec3d0eed1599d72421acbfa1703d /configure.ac
parentIPC namespaces also isolate POSIX message queues (diff)
downloadkernel-qcow2-util-linux-c42a6d4d340b2f829369eae19ec2d888d33cb433.tar.gz
kernel-qcow2-util-linux-c42a6d4d340b2f829369eae19ec2d888d33cb433.tar.xz
kernel-qcow2-util-linux-c42a6d4d340b2f829369eae19ec2d888d33cb433.zip
build-sys: fix empty package release number
Was broken for major releases since b0e6b25e: $ blkid -V blkid from util-linux 2.28 (libblkid 2.28., 12-Apr-2016) Now we also set 0 in this case, like: $ blkid -V blkid from util-linux 2.30 (libblkid 2.30.0, 12-Apr-2016) Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b17ccd69b..8391c00c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,10 +23,8 @@ dnl version details from <major>.<minor>[-<suffix>]
PACKAGE_VERSION_MAJOR=$(echo $PACKAGE_VERSION | awk -F. '{print $1}')
PACKAGE_VERSION_MINOR=$(echo $PACKAGE_VERSION | awk -F. '{print $2}' \
| awk -F- '{print $1}')
-
-PACKAGE_VERSION_RELEASE=$(echo $PACKAGE_VERSION | awk -F. '{print $3}' \
- | sed 's/.*@<:@^@<:@:digit:@:>@@:>@.*/0/')
-
+PACKAGE_VERSION_RELEASE=$(echo $PACKAGE_VERSION | awk -F. '{
+ print $3 ~ /^@<:@[0-9]@:>@+$/ ? $3 : 0}')
dnl libblkid version
LIBBLKID_VERSION="$PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_RELEASE"