summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRuediger Meier2015-01-20 14:55:57 +0100
committerRuediger Meier2015-01-20 15:38:06 +0100
commitc8494d88d9137ec6c885cae202f0ae6de930098c (patch)
tree4322c585cdaf250ad5354b38ab73406f507e9c1b /configure.ac
parentbuild-sys: free() needs stdlib.h (diff)
downloadkernel-qcow2-util-linux-c8494d88d9137ec6c885cae202f0ae6de930098c.tar.gz
kernel-qcow2-util-linux-c8494d88d9137ec6c885cae202f0ae6de930098c.tar.xz
kernel-qcow2-util-linux-c8494d88d9137ec6c885cae202f0ae6de930098c.zip
build-sys: fix UL_SCANF_TYPE_MODIFIER for icc
icc needs -Werror to let %m fail and to avoid this: ../libmount/src/tab_parse.c(61): warning #269: invalid format string conversion Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de299d341..a0d57631a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -492,6 +492,8 @@ int main()
return 1;
}])
+ul_save_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="-Werror ${CPPFLAGS}"
AC_CACHE_VAL([scanf_cv_alloc_modifier],
AC_RUN_IFELSE([AC_LANG_SOURCE([UL_SCANF_TYPE_MODIFIER(["%ms"])])],
[scanf_cv_alloc_modifier=ms],
@@ -525,6 +527,7 @@ AC_CACHE_VAL([scanf_cv_alloc_modifier],
[scanf_cv_alloc_modifier=no])]
)
)
+CPPFLAGS="$ul_save_CPPFLAGS"
AC_MSG_CHECKING([scanf string alloc modifiers])
AS_CASE([$scanf_cv_alloc_modifier],