summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola2013-07-28 23:11:20 +0200
committerKarel Zak2013-08-01 13:35:38 +0200
commitc8498f2fad2fe706a72540ab72dfd848f51af18a (patch)
tree3fc803ea7449b7f7ed5ecdc016572e8755c4a6ff /configure.ac
parentbuild-sys: prefer AS_IF rather than shell 'if' (diff)
downloadkernel-qcow2-util-linux-c8498f2fad2fe706a72540ab72dfd848f51af18a.tar.gz
kernel-qcow2-util-linux-c8498f2fad2fe706a72540ab72dfd848f51af18a.tar.xz
kernel-qcow2-util-linux-c8498f2fad2fe706a72540ab72dfd848f51af18a.zip
build-sys: use backticks rather than $() for commands in configure
The configure had both backticks and $() in use. These command susbstitutions are mutually interchangeable, so one should pick only one form. In this case backticks were favored because they are known with greater range of shells, making the backticks to be more portable. References: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/Shell-Substitutions.html#index-g_t_0024_0028_0040var_007bcommands_007d_0029-1632 Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6fae31e93..7252e9b35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1347,7 +1347,7 @@ AS_IF([test "x$enable_socket_activation" = xyes], [
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [directory for systemd service files]),
- [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+ [], [with_systemdsystemunitdir=`$PKG_CONFIG --variable=systemdsystemunitdir systemd`])
AS_IF([test "x$with_systemdsystemunitdir" != "xno"], [
AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
@@ -1359,8 +1359,8 @@ AM_CONDITIONAL([HAVE_SYSTEMD], [test -n "$with_systemdsystemunitdir" -a "x$with_
AC_ARG_WITH([bashcompletiondir],
AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),
[],
- [AS_IF([$($PKG_CONFIG --exists bash-completion)], [
- with_bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
+ [AS_IF([`$PKG_CONFIG --exists bash-completion`], [
+ with_bashcompletiondir=`$PKG_CONFIG --variable=completionsdir bash-completion`
], [
with_bashcompletiondir=${datadir}/bash-completion/completions
])