summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-08-15 12:45:20 +0200
committerKarel Zak2011-10-26 23:17:15 +0200
commitc94b3604f794c3e3794f055e43dd47526dffa9d7 (patch)
tree08314b0ec336f714386d93e8a081659953a79a05 /configure.ac
parentlogin: remove non-PAM code (diff)
downloadkernel-qcow2-util-linux-c94b3604f794c3e3794f055e43dd47526dffa9d7.tar.gz
kernel-qcow2-util-linux-c94b3604f794c3e3794f055e43dd47526dffa9d7.tar.xz
kernel-qcow2-util-linux-c94b3604f794c3e3794f055e43dd47526dffa9d7.zip
build-sys: require PAM for login-utils
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 88aced94f..66d0794f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1099,19 +1099,12 @@ AC_ARG_ENABLE([login-utils],
)
AM_CONDITIONAL(BUILD_LOGIN_UTILS, test "x$enable_login_utils" = xyes)
-AC_ARG_WITH([pam],
- [AS_HELP_STRING([--without-pam], [compile login-utils without PAM support])])
-
-AM_CONDITIONAL(HAVE_PAM, false)
-if test "x$enable_login_utils" = xyes && test "x$with_pam" != xno; then
- AC_CHECK_HEADERS([security/pam_misc.h],
- [AM_CONDITIONAL(HAVE_PAM, true)],
- [if test "x$with_pam" = xyes; then
- AC_MSG_ERROR([PAM selected but security/pam_misc.h not found])
- fi
- ])
+if test "x$enable_login_utils" = xyes; then
+ AC_CHECK_HEADERS([security/pam_misc.h], [],
+ [AC_MSG_ERROR([login-utils enabled, but security/pam_misc.h not found])])
fi
+
AC_ARG_WITH([selinux],
AS_HELP_STRING([--with-selinux], [compile with SELinux support]),
[], with_selinux=no