summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-05-29 15:20:44 +0200
committerKarel Zak2012-05-29 15:20:44 +0200
commitcc76731e7da26a48c306336a1d142d44186c2a26 (patch)
tree049cf8e02bc8789cee64227209075b6a9b4faa61 /configure.ac
parentbuild-sys: add --enable-newgrp (diff)
downloadkernel-qcow2-util-linux-cc76731e7da26a48c306336a1d142d44186c2a26.tar.gz
kernel-qcow2-util-linux-cc76731e7da26a48c306336a1d142d44186c2a26.tar.xz
kernel-qcow2-util-linux-cc76731e7da26a48c306336a1d142d44186c2a26.zip
build-sys: add --enable-vipw
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index c586481fb..b06c5bb1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -635,7 +635,7 @@ if test "x$enable_most_builds" = xyes; then
enable_line=yes
enable_mesg=yes
enable_reset=yes
- enable_login_utils=yes
+ enable_vipw=yes
enable_chfn_chsh=yes
enable_newgrp=yes
enable_write=yes
@@ -1020,13 +1020,12 @@ UL_BUILD_INIT([reset])
AM_CONDITIONAL(BUILD_RESET, test "x$build_reset" = xyes)
-AC_ARG_ENABLE([login-utils],
- AS_HELP_STRING([--enable-login-utils], [build vipw]),
- [], enable_login_utils=no
+AC_ARG_ENABLE([vipw],
+ AS_HELP_STRING([--enable-vipw], [build vipw]),
+ [], enable_vipw=no
)
-UL_BUILD_INIT([login_utils])
-UL_REQUIRES_HAVE([login_utils], [security_pam_misc_h], [PAM header file])
-AM_CONDITIONAL(BUILD_LOGIN_UTILS, test "x$build_login_utils" = xyes)
+UL_BUILD_INIT([vipw])
+AM_CONDITIONAL(BUILD_VIPW, test "x$build_vipw" = xyes)
AC_ARG_ENABLE([newgrp],