summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-08-18 13:33:27 +0200
committerKarel Zak2009-09-22 15:26:18 +0200
commitd46a54994e30da03385b82f64eaecffe5c170c92 (patch)
tree8e6b308066d1744e4801cae9186f44661f69100c /configure.ac
parentmount: document changed semantics of tmpfs size option in mount.8 (diff)
downloadkernel-qcow2-util-linux-d46a54994e30da03385b82f64eaecffe5c170c92.tar.gz
kernel-qcow2-util-linux-d46a54994e30da03385b82f64eaecffe5c170c92.tar.xz
kernel-qcow2-util-linux-d46a54994e30da03385b82f64eaecffe5c170c92.zip
fallocate: new command
The fallocate(1) utility is used to preallocate blocks to a file. This can be useful for virtual images, database files, testing, etc. Normally we'd hope that various tools will start using preallocation internally, but until then such a utility may be useful, and could be scripted as well. The original Eric's version is available at: http://thread.gmane.org/gmane.linux.utilities.util-linux-ng/2490 This version: - checks for fallocate glibc function and kernel syscall - does not provide a fallback and does not call posix_fallocate() - adds long options - uses err.h for errro messages - adds NLS support - cleanups man page Co-Author: Eric Sandeen <sandeen@redhat.com> Signed-off-by: Eric Sandeen <sandeen@redhat.com> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9944270ec..52985137c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -558,6 +558,9 @@ UTIL_CHECK_SYSCALL([ioprio_get],
[sh*], [289],
[x86_64*], [252])
+dnl fallocate could be available as libc function or as syscall only
+UTIL_CHECK_SYSCALL([fallocate])
+AC_CHECK_FUNCS([fallocate])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <time.h>