summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola2013-02-10 22:33:39 +0100
committerKarel Zak2013-02-14 10:11:13 +0100
commitd6abf1685da8f7d2aa0ddc74eb416a55df1208f8 (patch)
tree2a33a97425b77f57fa5ab21996bb1e34941b3d75 /configure.ac
parentlibmount: add missing MNT_ERR_AMBIFS (diff)
downloadkernel-qcow2-util-linux-d6abf1685da8f7d2aa0ddc74eb416a55df1208f8.tar.gz
kernel-qcow2-util-linux-d6abf1685da8f7d2aa0ddc74eb416a55df1208f8.tar.xz
kernel-qcow2-util-linux-d6abf1685da8f7d2aa0ddc74eb416a55df1208f8.zip
build-sys: use AC_COMPILE_IFELSE
The AC_TRY_COMPILE is obsolete. Addresses: http://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/autoconf-2.69/html_node/Obsolete-Macros.html#index-AC_005fTRY_005fCOMPILE-2203 Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 13 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 4a7979510..ae19de81a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,13 +375,19 @@ no:no)
esac
-AC_MSG_CHECKING(whether program_invocation_short_name is defined)
-AC_TRY_COMPILE([#include <argp.h>],
- [program_invocation_short_name = "test";],
- AC_DEFINE(HAVE_PROGRAM_INVOCATION_SHORT_NAME, 1,
- [Define if program_invocation_short_name is defined])
- AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no))
+AC_MSG_CHECKING([whether program_invocation_short_name is defined])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <argp.h>
+]], [[
+ program_invocation_short_name = "test";
+]])], [
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_PROGRAM_INVOCATION_SHORT_NAME], [1],
+ [Define if program_invocation_short_name is defined])
+], [
+ AC_MSG_RESULT([no])
+])
+
AC_MSG_CHECKING([whether __progname is defined])
AC_LINK_IFELSE([AC_LANG_PROGRAM([extern char *__progname;],