summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2014-05-21 13:35:01 +0200
committerKarel Zak2014-05-21 13:35:01 +0200
commitd6ace0b8dddd72b6cc8e4e8803407a5bb7171a42 (patch)
treef5196df99a5789925e5a942ad8825b15fcf26a7f /configure.ac
parentbuild-sys: add BUILD_GETOPT (diff)
downloadkernel-qcow2-util-linux-d6ace0b8dddd72b6cc8e4e8803407a5bb7171a42.tar.gz
kernel-qcow2-util-linux-d6ace0b8dddd72b6cc8e4e8803407a5bb7171a42.tar.xz
kernel-qcow2-util-linux-d6ace0b8dddd72b6cc8e4e8803407a5bb7171a42.zip
build-sys: add BUILD_CHRT
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d5b33a601..aa7bf1ca7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1426,13 +1426,13 @@ UL_REQUIRES_LINUX([setterm])
UL_REQUIRES_HAVE([setterm], [ncurses], [ncurses library])
AM_CONDITIONAL([BUILD_SETTERM], [test "x$build_setterm" = xyes])
-
+# build_schedutils= is just configure-only variable to control
+# ionice, taskset and chrt
AC_ARG_ENABLE([schedutils],
AS_HELP_STRING([--disable-schedutils], [do not build chrt, ionice, taskset]),
[], [enable_schedutils=yes]
)
UL_BUILD_INIT([schedutils])
-AM_CONDITIONAL([BUILD_SCHEDUTILS], [test "x$build_schedutils" = xyes])
UL_BUILD_INIT([ionice], [check])
UL_REQUIRES_BUILD([ionice], [schedutils])
@@ -1470,6 +1470,10 @@ UL_REQUIRES_SYSCALL_CHECK([taskset],
[sched_getaffinity])
AM_CONDITIONAL([BUILD_TASKSET], [test "x$build_taskset" = xyes])
+UL_BUILD_INIT([chrt], [check])
+UL_REQUIRES_BUILD([chrt], [schedutils])
+AM_CONDITIONAL([BUILD_CHRT], [test "x$build_chrt" = xyes])
+
AC_ARG_ENABLE([wall],
AS_HELP_STRING([--disable-wall], [do not build wall]),