summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-08-19 14:57:21 +0200
committerKarel Zak2013-08-19 14:57:21 +0200
commitd78df0ac6546bfe5500ca97f2bf05153d93e1eef (patch)
treeb8a3d6b9cbe97c945b487ab7ef9488d08ccb0bb5 /configure.ac
parentbuild-sys: remove deprecated elvtune command (diff)
downloadkernel-qcow2-util-linux-d78df0ac6546bfe5500ca97f2bf05153d93e1eef.tar.gz
kernel-qcow2-util-linux-d78df0ac6546bfe5500ca97f2bf05153d93e1eef.tar.xz
kernel-qcow2-util-linux-d78df0ac6546bfe5500ca97f2bf05153d93e1eef.zip
build-sys: add pylibmount
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 443ad7215..982606eb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1373,6 +1373,27 @@ AC_ARG_ENABLE([bash-completion],
AM_CONDITIONAL([BUILD_BASH_COMPLETION], [test "x$enable_bash_completion" = xyes])
+AC_ARG_WITH([python],
+ AS_HELP_STRING([--without-python], [do not generate python bindings]),
+ [], [with_python=yes]
+)
+have_python=no
+AS_IF([test "x$with_python" = xyes], [
+ AM_PATH_PYTHON([2.4])
+ AS_IF([test -x "$PYTHON-config"], [
+ have_python=yes
+ PYTHON_INCLUDES=$($PYTHON-config --includes)
+ AC_SUBST(PYTHON_INCLUDES)
+ ])
+])
+
+
+UL_BUILD_INIT([pylibmount], [check])
+UL_REQUIRES_HAVE([pylibmount], [python])
+UL_REQUIRES_BUILD([pylibmount], [libmount])
+AM_CONDITIONAL([BUILD_PYLIBMOUNT], [test "x$build_pylibmount" = "xyes"])
+
+
AC_ARG_ENABLE([pg-bell],
AS_HELP_STRING([--disable-pg-bell], [let pg not ring the bell on invalid keys]),
[], [enable_pg_bell=yes]