summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-09-27 12:03:33 +0200
committerKarel Zak2013-09-27 12:03:33 +0200
commitd924b10b941ec0e31ca3be18e5399adb726edcfc (patch)
tree2aa4b3dd0d9556a861751a6c1208fffa48e2f6bf /configure.ac
parentlibblkid: update docs (diff)
downloadkernel-qcow2-util-linux-d924b10b941ec0e31ca3be18e5399adb726edcfc.tar.gz
kernel-qcow2-util-linux-d924b10b941ec0e31ca3be18e5399adb726edcfc.tar.xz
kernel-qcow2-util-linux-d924b10b941ec0e31ca3be18e5399adb726edcfc.zip
build-sys: fix static builds
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 22e00448d..79d11da93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,7 +390,7 @@ AC_ARG_ENABLE([static-programs],
AS_CASE([$enable_static_programs],
[yes],
- [enable_static_programs=m4_quote([UL_STATIC_PROGRAMS])],
+ [enable_static_programs=m4_quote(UL_STATIC_PROGRAMS)],
[no],
[enable_static_programs=]
)
@@ -400,6 +400,7 @@ m4_foreach([UL_PRG], m4_defn([UL_STATIC_PROGRAMS]), [
AS_CASE([,$enable_static_programs,],
[*,UL_PRG,*], [static_[]UL_PRG=yes]
)
+ AS_IF([test "x$static_[]UL_PRG" = xyes], [AC_MSG_NOTICE([enable static build: UL_PRG.])])
AM_CONDITIONAL([HAVE_STATIC_]m4_toupper(UL_PRG),
[test "x$static_[]UL_PRG" = xyes])
])
@@ -1399,11 +1400,12 @@ AS_IF([test "x$with_python" != xno], [
[yes:no],
[AC_MSG_ERROR([python selected but libpython not found])],
)
+
+ UL_BUILD_INIT([pylibmount], [check])
+ UL_REQUIRES_HAVE([pylibmount], [python], [libpython])
+ UL_REQUIRES_BUILD([pylibmount], [libmount])
])
-UL_BUILD_INIT([pylibmount], [check])
-UL_REQUIRES_HAVE([pylibmount], [python])
-UL_REQUIRES_BUILD([pylibmount], [libmount])
AM_CONDITIONAL([BUILD_PYLIBMOUNT], [test "x$build_pylibmount" = "xyes"])