summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2010-11-15 16:42:45 +0100
committerKarel Zak2010-11-15 16:42:45 +0100
commitdc61d398ba14a38f13aeab3be9e9e09f7f117179 (patch)
tree97cf17e9c52a4fb387c379ed7a40eaa3f1ff3ed6 /configure.ac
parentlib/tt: fix langinfo build break (diff)
downloadkernel-qcow2-util-linux-dc61d398ba14a38f13aeab3be9e9e09f7f117179.tar.gz
kernel-qcow2-util-linux-dc61d398ba14a38f13aeab3be9e9e09f7f117179.tar.xz
kernel-qcow2-util-linux-dc61d398ba14a38f13aeab3be9e9e09f7f117179.zip
lib: add fallback for nl_langinfo()
The fallback ignores locales and returns hardcoded static strings. It should be enough to include "nls.h" to work with nl_langinfo() on all systems. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 561424a63..ca3e4af5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,7 +110,6 @@ AC_CHECK_HEADERS(
[err.h \
errno.h \
getopt.h \
- langinfo.h \
linux/fd.h \
linux/tiocl.h \
linux/version.h \
@@ -146,10 +145,16 @@ AC_CHECK_HEADERS(
sys/user.h \
sys/resource.h \
unistd.h ])
+
AC_CHECK_HEADERS([linux/raw.h],
[AM_CONDITIONAL([HAVE_RAW], [true])],
[AM_CONDITIONAL([HAVE_RAW], [false])])
+AC_CHECK_HEADERS([langinfo.h],
+ [AM_CONDITIONAL([HAVE_LANGINFO], [true])],
+ [AM_CONDITIONAL([HAVE_LANGINFO], [false])])
+
+
AC_CHECK_DECLS([_NL_TIME_WEEK_1STDAY],[],[],[[#include <langinfo.h>]])
AC_CHECK_DECL([llseek],