summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-03-12 15:16:09 +0100
committerKarel Zak2012-03-12 15:16:09 +0100
commitde2174895aa2870610b2495f985dc858a3a15b92 (patch)
treea63a5b2f14c42de5b95295e931751592351e6a5c /configure.ac
parentbuild-sys: note sulogin in configure help (diff)
downloadkernel-qcow2-util-linux-de2174895aa2870610b2495f985dc858a3a15b92.tar.gz
kernel-qcow2-util-linux-de2174895aa2870610b2495f985dc858a3a15b92.tar.xz
kernel-qcow2-util-linux-de2174895aa2870610b2495f985dc858a3a15b92.zip
build-sys: add --diable-sulogin (enabled by default)
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 034850644..4d3da7d7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -760,6 +760,14 @@ UL_REQUIRES_BUILD([mountpoint], [libmount])
AM_CONDITIONAL(BUILD_MOUNTPOINT, test "x$build_mountpoint" = xyes)
+AC_ARG_ENABLE([sulogin],
+ AS_HELP_STRING([--disable-sulogin], [do not build sulogin]),
+ [], enable_sulogin=yes
+)
+UL_BUILD_INIT([sulogin])
+AM_CONDITIONAL(BUILD_SULOGIN, test "x$build_sulogin" = xyes)
+
+
AC_ARG_ENABLE([fallocate],
AS_HELP_STRING([--disable-fallocate], [do not build fallocate]),
[], enable_fallocate=check
@@ -986,7 +994,7 @@ AM_CONDITIONAL(BUILD_RESET, test "x$build_reset" = xyes)
AC_ARG_ENABLE([login-utils],
- AS_HELP_STRING([--enable-login-utils], [build chfn, chsh, login, sulogin, newgrp, vipw]),
+ AS_HELP_STRING([--enable-login-utils], [build chfn, chsh, login, newgrp, vipw]),
[], enable_login_utils=no
)
UL_BUILD_INIT([login_utils])