summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-27 17:04:49 +0200
committerKarel Zak2011-11-03 12:32:51 +0100
commite09ebf22253b2c1b48ba80110a88b01935c94cc3 (patch)
treebddfe0a03cfc0944a8457a9089cb430bc9534995 /configure.ac
parentbuild-sys: cleanup BUILD_{WALL,WRITE} (diff)
downloadkernel-qcow2-util-linux-e09ebf22253b2c1b48ba80110a88b01935c94cc3.tar.gz
kernel-qcow2-util-linux-e09ebf22253b2c1b48ba80110a88b01935c94cc3.tar.xz
kernel-qcow2-util-linux-e09ebf22253b2c1b48ba80110a88b01935c94cc3.zip
build-sys: cleanup BUILD_HWCLOCK
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 55a78175b..d2c1d8e29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -286,9 +286,7 @@ AC_CHECK_FUNCS(
AC_FUNC_FSEEKO
AC_CHECK_FUNCS([openat fstatat unlinkat], [have_openat=yes], [have_openat=no])
-
AC_CHECK_FUNCS([ioperm iopl], [have_io=yes])
-AM_CONDITIONAL([BUILD_HWCLOCK], test "x$have_io" = xyes -o "x$linux_os" = xyes)
AC_CHECK_MEMBER(struct sockaddr.sa_len,
AC_DEFINE_UNQUOTED(HAVE_SA_LEN,1,[Define if struct sockaddr contains sa_len]),,
@@ -832,6 +830,12 @@ UL_REQUIRES_HAVE([cramfs], [z], [z library])
AM_CONDITIONAL(BUILD_CRAMFS, test "x$build_cramfs" = xyes)
+if test "x$have_io" = xyes -o "x$linux_os" = xyes; then
+ build_hwclock=yes
+fi
+AM_CONDITIONAL(BUILD_HWCLOCK, test "x$build_hwclock" = xyes)
+
+
enable_lsblk=check
build_lsblk=yes
UL_REQUIRES_LINUX([lsblk])