summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCasper Ti. Vector2015-11-19 03:52:14 +0100
committerKarel Zak2015-11-19 12:07:04 +0100
commite52b58e6277141ffd3d196b636515096d7a1ce44 (patch)
tree8bb13e72f3b7db1fdb71713fe6b327a2310b2c1f /configure.ac
parentlosetup: clean up --direct-io (diff)
downloadkernel-qcow2-util-linux-e52b58e6277141ffd3d196b636515096d7a1ce44.tar.gz
kernel-qcow2-util-linux-e52b58e6277141ffd3d196b636515096d7a1ce44.tar.xz
kernel-qcow2-util-linux-e52b58e6277141ffd3d196b636515096d7a1ce44.zip
ctrlaltdel: use reboot() provided by libc, assuming it is 1-adic.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6748dd2a5..6075f7207 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,6 +378,7 @@ AC_CHECK_FUNCS([ioperm iopl], [have_io=yes])
AC_CHECK_FUNCS([futimens], [have_futimens=yes])
AC_CHECK_FUNCS([inotify_init1], [have_inotify_init1=yes])
AC_CHECK_FUNCS([open_memstream], [have_open_memstream=yes],[have_open_memstream=no])
+AC_CHECK_FUNCS([reboot], [have_reboot=yes],[have_reboot=no])
dnl lib/mononotic.c may require -lrt
AC_CHECK_FUNCS([clock_gettime], [],
@@ -1420,6 +1421,11 @@ AM_CONDITIONAL([BUILD_DMESG], [test "x$build_dmesg" = xyes])
UL_BUILD_INIT([ctrlaltdel], [check])
UL_REQUIRES_LINUX([ctrlaltdel])
+dnl we assume reboot() to be the 1-argument variant, because even considering
+dnl widely used alternative C libraries like uclibc, dietlibc and musl,
+dnl reboot() with multiple arguments is yet only found in glibc versions
+dnl earlier than 2.x.
+UL_REQUIRES_HAVE([ctrlaltdel], [reboot])
AM_CONDITIONAL([BUILD_CTRLALTDEL], [test "x$build_ctrlaltdel" = xyes])
UL_BUILD_INIT([fsfreeze], [check])