summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2016-10-20 16:52:31 +0200
committerKarel Zak2016-10-20 16:52:31 +0200
commite5cc93b5a8854fce80537f86a244977df212dcb5 (patch)
tree194c92f61f5f3eeb6f864428ae37a00e7865bf75 /configure.ac
parentbuild-sys: release++ (v2.29-rc2) (diff)
downloadkernel-qcow2-util-linux-e5cc93b5a8854fce80537f86a244977df212dcb5.tar.gz
kernel-qcow2-util-linux-e5cc93b5a8854fce80537f86a244977df212dcb5.tar.xz
kernel-qcow2-util-linux-e5cc93b5a8854fce80537f86a244977df212dcb5.zip
build-sys: use ncurses-config rather than pkg-config
It's painful, but ncurses upstream does not distribute .pc files by default and it seems that ncurses{6,5}-config is the preferred solution. For better compatibility lets use ncurses-config. Reported-by: Ruediger Meier <sweet_f_a@gmx.de> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 61264b1c2..66601ecf3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -778,14 +778,12 @@ AC_ARG_WITH([ncursesw],
)
have_ncursesw=no
AS_IF([test "x$with_ncursesw" != xno], [
- PKG_CHECK_MODULES(NCURSESW, [ncursesw], [
- have_ncursesw=yes
- NCURSES_LIBS=${NCURSESW_LIBS}
- NCURSES_CFLAGS=${NCURSESW_CFLAGS}
+ UL_NCURSES_CHECK([ncursesw])
+ AS_IF([test "x$have_ncursesw" = xyes], [
AC_DEFINE([HAVE_LIBNCURSESW], [1], [Define if ncursesw library available])
CURSES_LIB_NAME="ncursesw"
AC_CHECK_HEADERS([ncursesw/ncurses.h ncurses.h])
- ], [have_ncursesw=no])
+ ])
])
AS_CASE([$with_ncursesw:$have_ncursesw],
[yes:no], [AC_MSG_ERROR([ncursesw selected, but library not found])])
@@ -802,12 +800,12 @@ AS_CASE([$with_ncurses:$build_widechar],
[yes:yes], [AC_MSG_ERROR([wide-char support enabled, but non-wide ncurses selects])])
AS_IF([test "x$have_ncursesw" = xno -a "x$with_ncurses" != xno ], [
- PKG_CHECK_MODULES(NCURSES, [ncurses], [
- have_ncurses=yes
+ UL_NCURSES_CHECK([ncurses])
+ AS_IF([test "x$have_ncurses" = xyes], [
AC_DEFINE([HAVE_LIBNCURSES], [1], [Define if ncurses library available])
CURSES_LIB_NAME="ncurses"
AC_CHECK_HEADERS([ncurses/ncurses.h ncurses.h])
- ],[have_ncurses=no])
+ ])
])
AS_CASE([$with_ncurses:$have_ncurses],
[yes:no], [AC_MSG_ERROR([ncurses selected, but library not found])])