summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-05-29 14:14:38 +0200
committerKarel Zak2012-05-29 14:17:05 +0200
commite7614a0780cd0591eca30116563461a18cb7ba49 (patch)
treef2a9f4e1557f84b87220ec82888ac5b376478972 /configure.ac
parentsu: remove program_name (diff)
downloadkernel-qcow2-util-linux-e7614a0780cd0591eca30116563461a18cb7ba49.tar.gz
kernel-qcow2-util-linux-e7614a0780cd0591eca30116563461a18cb7ba49.tar.xz
kernel-qcow2-util-linux-e7614a0780cd0591eca30116563461a18cb7ba49.zip
build-sys: add --disable-login
... to implement fine-grained control on what is built from login-utils. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 17 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index cd8fa4efd..83d4c6d4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -777,14 +777,6 @@ UL_REQUIRES_BUILD([mountpoint], [libmount])
AM_CONDITIONAL(BUILD_MOUNTPOINT, test "x$build_mountpoint" = xyes)
-AC_ARG_ENABLE([sulogin],
- AS_HELP_STRING([--disable-sulogin], [do not build sulogin]),
- [], enable_sulogin=yes
-)
-UL_BUILD_INIT([sulogin])
-AM_CONDITIONAL(BUILD_SULOGIN, test "x$build_sulogin" = xyes)
-
-
AC_ARG_ENABLE([fallocate],
AS_HELP_STRING([--disable-fallocate], [do not build fallocate]),
[], enable_fallocate=check
@@ -1027,7 +1019,7 @@ AM_CONDITIONAL(BUILD_RESET, test "x$build_reset" = xyes)
AC_ARG_ENABLE([login-utils],
- AS_HELP_STRING([--enable-login-utils], [build chfn, chsh, login, newgrp, vipw]),
+ AS_HELP_STRING([--enable-login-utils], [build chfn, chsh, newgrp, vipw]),
[], enable_login_utils=no
)
UL_BUILD_INIT([login_utils])
@@ -1035,6 +1027,22 @@ UL_REQUIRES_HAVE([login_utils], [security_pam_misc_h], [PAM header file])
AM_CONDITIONAL(BUILD_LOGIN_UTILS, test "x$build_login_utils" = xyes)
+AC_ARG_ENABLE([login],
+ AS_HELP_STRING([--disable-login], [do not build login]),
+ [], enable_login=yes
+)
+UL_BUILD_INIT([login])
+UL_REQUIRES_HAVE([login], [security_pam_misc_h], [PAM header file])
+AM_CONDITIONAL(BUILD_LOGIN, test "x$build_login" = xyes)
+
+
+AC_ARG_ENABLE([sulogin],
+ AS_HELP_STRING([--disable-sulogin], [do not build sulogin]),
+ [], enable_sulogin=yes
+)
+UL_BUILD_INIT([sulogin])
+AM_CONDITIONAL(BUILD_SULOGIN, test "x$build_sulogin" = xyes)
+
AC_ARG_ENABLE([schedutils],
AS_HELP_STRING([--disable-schedutils], [do not build chrt, ionice, teskset]),