summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-01-11 17:05:08 +0100
committerKarel Zak2012-01-11 17:05:08 +0100
commitecdba5ddfc99815181db1e5d571ea8e2b806c0f9 (patch)
treec28a9b435950b164dea72b39916e393adfb36c7b /configure.ac
parentlibmount: add --pass-fd to samples/mount (diff)
downloadkernel-qcow2-util-linux-ecdba5ddfc99815181db1e5d571ea8e2b806c0f9.tar.gz
kernel-qcow2-util-linux-ecdba5ddfc99815181db1e5d571ea8e2b806c0f9.tar.xz
kernel-qcow2-util-linux-ecdba5ddfc99815181db1e5d571ea8e2b806c0f9.zip
build-sys: add --enable-new-mount
Now we have three versions of the mount(8) utility * old mount(8) --enable-mount [default] * old mount(8) linked with libmount This is this is necessary for systems without mtab file. --enable-libmount-mount - new mount(8) This is completely new pure-libmount based mount(8). --enable-new-mount Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e30c8df33..8af42e435 100644
--- a/configure.ac
+++ b/configure.ac
@@ -697,7 +697,7 @@ AM_CONDITIONAL(BUILD_LOSETUP, test "x$build_losetup" = xyes)
AC_ARG_ENABLE([libmount-mount],
- AS_HELP_STRING([--enable-libmount-mount], [link mount(8) with libmount (EXPERIMENTAL)]),
+ AS_HELP_STRING([--enable-libmount-mount], [link old mount(8) with libmount]),
[], enable_libmount_mount=no
)
UL_BUILD_INIT([libmount_mount])
@@ -709,6 +709,18 @@ fi
AM_CONDITIONAL(BUILD_LIBMOUNT_MOUNT, test "x$build_libmount_mount" = xyes)
+AC_ARG_ENABLE([new-mount],
+ AS_HELP_STRING([--enable-new-mount], [build new pure libmount based mount(8) (EXPERIMENTAL)]),
+ [], enable_new_mount=no
+)
+UL_BUILD_INIT([new_mount])
+UL_REQUIRES_BUILD([new_mount], [libmount])
+if test "x$build_new_mount" = xyes; then
+ AM_CONDITIONAL(BUILD_MOUNT, [false])
+fi
+AM_CONDITIONAL(BUILD_NEW_MOUNT, test "x$build_new_mount" = xyes)
+
+
AC_ARG_ENABLE([fsck],
AS_HELP_STRING([--disable-fsck], [do not build fsck]),
[], enable_fsck=check
@@ -1180,7 +1192,6 @@ libmount/src/Makefile
libmount/src/libmount.h
libmount/docs/Makefile
libmount/docs/version.xml
-libmount/samples/Makefile
libuuid/uuid.pc
libuuid/Makefile
libuuid/man/Makefile